subscription-manager: Why am I unable to download some content (like FasTrack) or getting 'too many content sets for certificate' error?

Solution Verified - Updated

Environment

  • Red Hat Subscription Manager (RHSM) on Red Hat Enterprise Linux
    • RHEL 5.7
    • RHEL 5.8
    • RHEL 5.9
    • RHEL 6.1
    • RHEL 6.2
    • RHEL 6.3
    • RHEL 6.4
  • Red Hat Customer Portal / Subscription Asset Management (SAM) Organization, SAM versions 1.2 and earlier

Issue

  • Unable to download certain packages (like FasTrack) when using subscription manager
  • Problem registering or subscribing due to cert error: 'Too many content sets for certificate. A newer client may be available to address this problem.'
  • Not able to attach some subscriptions (such as Red Hat Enterprise Linux Academic Site Subscription (Server, Desktop, Workstation, POWER)), or above a number of subscriptions, to Subscription Asset Management Organization

Resolution

  • Download missing rpms (like FasTrack) manually from This content is not included.Red Hat Content Delivery Network

  • Upgrade to the latest Red Hat Enterprise Linux 5 or Red Hat Enterprise Linux 6 subscription-manager package and re-generate the certificates. Note that you may also need to install the latest python-rhsm package at the same time to meet dependency requirements.

  • SAM 1.2 and earlier (1.1) does not support subscriptions which require larger content sets. Please refer to the This content is not included.SAM product documentation about
    upgrading to the latest version which supports the new certificate format.

  • In case of offline system registration, attach the subscription with more content sets just by specifying the upgraded RHEL version as RHEL6.4 or above(in case of RHEL6 offline registration) and RHEL5.9 and above (in case of RHEL5 offline registration) while creating profile for system on This content is not included.Customer Portal. Ensure that system has latest version of subscription-manager and python-rhsm packages installed.

Root Cause

  • Some content is currently unavailable if you are using an older version of Subscription Manager to download rpms. Most content is available now in the most recent versions of Red Hat Enterprise Linux 5 and Red Hat Enterprise Linux 6 subscription-manager.

  • For customers in fully disconnected environments who are manually creating systems in the Customer Portal, this message means that you cannot access the subscription you have requested without updating your client.

Diagnostic Steps

  • If you encounter dependency error message as following while updating subscription-manager, please refer to this solution to solve the issue.
Error: Package: subscription-manager-gnome-0.99.19.4-1.el6_3.x86_64 (rhel-x86_64-server-6)
           Requires: subscription-manager = 0.99.19.4-1.el6_3
SBR
Category

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.