Registering the system using subscription-manager fails with Unable to find available subscriptions for all your installed products.

Solution Verified - Updated

Environment

  • Red Hat Enterprise Atomic Host
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Virtualization
  • Red Hat Subscription Manager
  • Red Hat Subscription Asset Manager
  • Red Hat Satellite 6.x

Issue

  • Registering the system using subscription-manager fails with message "Unable to find available subscriptions for all your installed products".

    # subscription-manager register --username=XXX --password=XXX --auto-attach
    
  • Registering the system using activation-key fails with message "Unable to find available subscriptions for all your installed products" .

       # subscription-manager register --org=XXX --activationkey=XXX
      The system has been registered with ID: XXX-XXX-XXX-XXX-XXX
      The registered system name is: client.example.com
    
       Installed Product Current Status:
       Product Name: Red Hat Enterprise Linux Server
       Status:       Not Subscribed
    
       Unable to find available subscriptions for all your installed products.
    

Resolution

  • Try to make subscriptions available by removing it from inactive systems.

  • If the system is being registered to Red Hat Satellite 6 server, then verify whether the Satellite 6 manifest file has been updated to include all the available subscriptions. You may refer the documentation for the steps to add available subscriptions in Satellite 6 manifest file.

  • If the system is being registered to the Red Hat Satellite 6 server with the activation key:

    • If auto-attach is marked as No in the activation key and same subscriptions are to attached to different client machine then confirm if the required RHEL subscription/subscriptions are added into the activation key and not only custom subscriptions are added into the Activation key
    • If auto-attach is marked as Yes in activation key and the client machine is still not getting subscribed, then check the entitlement status for that particular subscription/subscriptions.
  • Ensure only required product certificate files are present under /etc/pki/product/ directory on system being registered. Move the additional product certificate file present on system to some other location. You can use below command to get the details of product certificate file.

    # rct cat-cert /etc/pki/product/<pem_file>
    
  • If the system being registered is reported in Red Hat Satellite 6 by virt-who, configure the activation key as per the solution.

  • To purchase additional subscriptions, contact This content is not included.Red Hat Sales. For any other assistance, contact Red Hat Technical Support.

For more KB articles/solutions related to Red Hat Satellite 6.x Client Subscription Issues, please refer to the Red Hat Satellite Consolidated Troubleshooting Article for Red Hat Satellite 6.x Client Subscription Issues

Root Cause

  • This message is returned when there are no free available subscription that can be attached to this system.

Diagnostic Steps

  • To check the subscription consumption status on Satellite CLI, refer to this article.

  • To check the subscription consumption status on Satellite WebUI,

    • Go to Content > Subscriptions
SBR
Category

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