How to prevent duplicate of replaced systems in Hybrid Cloud Console Inventory ?

Solution Verified - Updated

Environment

  • Red Hat Enterprise Linux v 6
  • Red Hat Enterprise Linux v 7
  • Red Hat Enterprise Linux v 8
  • Red Hat Enterprise Linux v 9
  • Red Hat Enterprise Linux v 10
  • Certificate Based Registration
    • Hybrid Cloud Console
    • Red Hat Customer Portal
    • Red Hat Network Portal
    • Red Hat Subscription Management)

Issue

If a RHEL system is cloned or templated after it has already been registered to Red Hat Subscription Management (RHSM) or Red Hat Insights, the cloned system inherits the existing Insights Machine-id file, stored at:

/etc/insights-client/machine-id
  • During registration:
    • Subscription-manager register generates a new system UUID
    • The inherited Insights Machine-id is not automatically regenerated
    • Multiple systems may report using the same identity values

Resolution

Before cloning or templating

Before converting a system into a template or cloning it, ensure it is not registered to RHSM or Insights.

  1. Unregister the system from RHSM
# subscription-manager unregister
# subscription-manager clean
  1. Remove the Insights Machine-id
# rm -f /etc/insights-client/machine-id 
  1. Power off the system and create the template or clone the system

    • All systems created from this template will now generate a unique RHSM UUID and Insights Machine-id upon registration.

If systems are already replacing each other

  1. Remove existing subscription and identity data
# subscription-manager clean
  1. Remove the inherited Insights Machine-id
# rm -f /etc/insights-client/machine-id 
  1. Ensure system uniqueness

    • Verify that the cloned system has a unique hostname
  2. Register the system to RHSM and attach a subscription

# subscription-manager register 
  1. Register the system to Insights
# insights-client --register
  1. Validate in Hybrid Cloud Console
    • Log into: https://console.redhat.com/insights/inventory and confirm that the system appears as a unique entry and no longer replaces other systems.
  • Additional information
    • Re-running insights-client –register without removing /etc/insights-client/machine-id does not resolve the issue
    • Each RHEL system must have a unique Insights Machine-id to appear separately in Inventory
    • Behavior described in this article applies to supported RHEL versions where subscription-manager and insights-client are available. Extended Life Phase systems may require updated client packages.

Root Cause

Hybrid Cloud Console identifies systems using a host deduplication process that considers several identifiers, such as provider ID (for example, cloud instance ID), subscription manager UUID, and Insights Machine-ID. If multiple systems share identifiers, they may be merged or they may replace each other in inventory.

Therefore, cloning or templating a system after it has been registered can lead to duplicate or replaced hosts and is an unsupported workflow unless identity information is reset.

SBR
Category
Tags

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.