Generating a JDR and SOS report for JBoss EAP
Environment
- Red Hat JBoss Enterprise Application Platform (EAP)
- 8.x
- 7.x
- 6.x
Issue
- Steps involved in generating the JDR or SOS report
- How to generate a JDR report
Resolution
A JDR report can be generated in one of the following ways:
-
Using the
$JBOSS_HOME/bin/jdr.sh(jdr.baton Windows) script:- Execute the
jdr.shscript. - When prompted, provide the management user name and password.
The report will be generated in a zip file created in the current work directory.
Example:
[foo@localhost bin]$ ./jdr.sh Initializing JBoss Diagnostic Reporter... Management username: test Management password: JDR started: Fri Sep 21 11:19:33 CDT 2012 JDR ended: Fri Sep 21 11:19:57 CDT 2012 JDR location: /home/jboss-eap-6.0.GA/bin/sosreport-localhost.localdomain-20120921111942.zip - Execute the
-
Using the
$JBOSS_HOME/bin/jboss-cli.sh(jboss-cli.baton Windows) JBoss EAP CLI:-
Launch the JBoss EAP CLI:
$JBOSS_HOME/bin/jboss-cli.sh --connect -
Invoke the
subsystem=jdr/:generate-jdr-reportoperation. The complete path to the operation will depend on whether you are running your JBoss EAP instance in standalone or domain mode.-
For standalone mode:
/subsystem=jdr/:generate-jdr-report -
For domain mode, replace
$hostand$serverwith the target domain host and managed server name respectively:/host=$host/server=$server/subsystem=jdr/:generate-jdr-reportFor example, the following will collect data for master.server-one:
/host=master/server=server-one/subsystem=jdr/:generate-jdr-report
-
-
Note the following known issues and limitations:
- The JDR can be run off-line (when EAP is not running), however, it will collect less information than usual.
- If EAP is running in domain mode, then JDR will not automatically collect data from all nodes in the domain. It will need to be run manually for each host in the domain if the data is needed for all hosts.
- In versions previous to EAP 6.1.0 there was an issue where JDR does not work in Solaris/Sparc environments (see Content from issues.jboss.org is not included.JBPAPP-9565 for details), so update to the latest EAP version.
For SOS report generation:
The solution What is an sosreport and how to create one in Red Hat Enterprise Linux? provides more information on how to generate an SOS report.
Root Cause
When working with Red Hat support, it may be necessary to provide details regarding your environment along with relevant logs for your question or issue. In such cases, a JBoss Diagnostic Reporter (JDR, pronounced jitter) report may be requested.
The JDR is a subsystem available beginning with JBoss EAP 7/6. It was built to collect information to assist in troubleshooting.
JDR collects the following items:
- configuration files;
- log files;
- deployment information;
- runtime information (so long as EAP is running during collection);
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