Performance Issue due to server reached MaxRequestWorkers on Apache httpd

Solution Verified - Updated

Environment

  • Red Hat Enterprise Linux (RHEL)
  • Red Hat JBoss Enterprise Application Platform (EAP)
  • Red Hat JBoss Web Server (JWS)
  • Red Hat JBoss Core Services (JBCS)
  • Apache Web Server (httpd)

Issue

  • The Apache httpd hangs after reaching 256 connections. We see below error message in error_log.

       AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
    
  • The Apache httpd server is running out of MaxRequestWorkers very quickly. How to increase MaxRequestWorkers?

  • Httpd only allowing 256 connections in Prefork mpm

Resolution

Root Cause

  • The amount of traffic was greater than the request worker limit specified in directive MaxRequestWorkers, exhausting httpd's thread pool.
  • The Prefork MPM ServerLimit defaults to 256, so if the MaxRequestWorkers is increased beyond that number, Apache httpd will throw a warning message and truncate the MaxRequestWorkers down to 250.
Components
Category
Tags

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.