There is insufficient memory for the Java Runtime Environment to continue

Solution Verified - Updated

Environment

  • Red Hat Enterprise Linux
  • Windows

Issue

  • When starting the Java application (e.g. JBoss) the following error is thrown:
There is insufficient memory for the Java Runtime Environment to continue..

Resolution

Root Cause

Diagnostic Steps

On RHEL8+, check if the data limit is restricted (set to something other than unlimited):

$ ulimit -d
131072
  • Inspect/compare java -version output to make sure the JVM is not unexpectedly 32-bit:
$ java -version
$ java -d32 -version (Solaris/Linux)
$ java -d64 -version (Solaris/Linux)
Components

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.