NullPointerException at com.arjuna.ats.arjuna.StateManager.unpackHeader in EAP 6

Solution Unverified - Updated

Environment

  • Red Hat JBoss Enterprise Application Platform (EAP) 6

Issue

2016-05-31 12:39:42,064 ERROR [stderr] (EJB default - 1) java.io.IOException: java.lang.NullPointerException
... 	at com.arjuna.ats.arjuna.StateManager.unpackHeader(StateManager.java:732)
... 	at com.arjuna.ats.internal.jta.transaction.arjunacore.subordinate.jca.SubordinateAtomicAction.<init>(SubordinateAtomicAction.java:82)
... 	at com.arjuna.ats.internal.jta.transaction.arjunacore.jca.XATerminatorImple.doRecover(XATerminatorImple.java:393)
... 	at org.jboss.as.ejb3.remote.EJBRemoteTransactionsRepository.getXidsToRecoverForParentNode(EJBRemoteTransactionsRepository.java:178)
... 	at org.jboss.as.ejb3.remote.protocol.versiontwo.TransactionRecoverMessageHandler$TxRecoveryTask.run(TransactionRecoverMessageHandler.java:98)
... 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
... 	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
... 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
... 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
... 	at java.lang.Thread.run(Thread.java:745)
... 	at org.jboss.threads.JBossThread.run(JBossThread.java:122)
... Caused by: java.lang.NullPointerException
... 	at com.arjuna.ats.arjuna.StateManager.unpackHeader(StateManager.java:697)
... 	...

Root Cause

The error indicates an unknown failure related to the use of EJB remoting + JTA

Diagnostic Steps

Collect the following Information

  1. Server configuration file => standalone*.xml/domain.xml
  2. Reproducer/testcase, if possible
  3. server.log from start up

Try to identify a pattern in the appearance of the failure with regard to the most recent EJB remoting + JTA operations.

Components
Category

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.