Some of JBoss EAP resource's connection settings get reset after applying EAP patch/update

Solution Unverified - Updated

Environment

  • Red Hat JBoss Operations Network (ON) 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7
  • Red Hat JBoss Enterprise Application Platform (EAP) 6 management plug-in for JBoss ON.
  • EAP resource is in inventory and being managed
  • Existing EAP server is updated or patched
  • The agent managing the EAP resource performs discovery

Issue

  • After patch or update of EAP resource, connection settings are reset to default
  • User name, password, and trust-store settings are reset back to the default values after EAP update

Resolution

This issue is resolved in JBoss ON 3.3 Update-08 (3.3.8). Please apply the latest update.

If you are not able to apply the latest supported update at this time, it will be necessary to rollback to the previous version of the connection settings. This can be done by going to the EAP 6 server resource's Inventory -> Connection Settings History page and selecting the previous settings row -- should be the second row of the list -- and then clicking the Rollback button located at the bottom. This will reapply the previous connection settings to the resource.

Root Cause

When the version identifier for the resource changes, a configuration merge is attempted for all connection setting properties that are at their default setting. However, this merge appears to be too broad and is impacting configuration values that are non-default. The result is that many connection settings get overwritten with their default discovered values.

This issue was originally identified as This content is not included.Red Hat Bugzilla 1379834.

Diagnostic Steps

  • Review Connection Settings History page for affected resource. There will be an entry created by user admin around the time the EAP server was upgraded or an update was applied.
SBR
Category

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.