Registering System to RHSM or Migrating System from RHN to RHSM Gives Error "System certificates corrupted. Please reregister."
Environment
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 5.7+
- Red Hat Satellite 6
- Red Hat Satellite 5.6+
Issue
- I am trying to register my RHEL system to RHSM using
subscription-manager registerand receive the below message:-
System certificates corrupted. Please reregister.
Resolution
- Unregister the system from RHSM:
# subscription-manager unregister
# subscription-manager clean
- Re-register the system to RHSM:
# subscription-manager register
- Auto-attach a subscription or attach a subscription by pool ID:
# subscription-manager attach --auto
OR
# subscription-manager attach --pool=<pool-ID>
- Enable the repositories you need on the system:
# subscription-manager repos --enable <repo-label-1> --enable <repo-label-2> --enable <repo-label-3>
- If still the issue persist remove all the present certificate files and place the certificate in /etc/pki/product and try the above resolution again.
Root Cause
-
The system's RHSM data became corrupt. Running
subscription-manager cleanduring the unregister/re-register process will remove corrupted data so that system can properly register again. -
Error "System certificates corrupted. Please reregister." can also result due to corrupt product certificate, replacing the certificate resolves the issue.
-
The system have corrupt certificate file in /etc/pki/product directory.
Diagnostic Steps
Running subscription-manager register gives the following output:
# subscription-manager register
Registering to: subscription.rhsm.redhat.com:443/subscription
Username: username
Password: ********
System certificates corrupted. Please reregister.
The system has been registered with ID: abcdef01-2345-6789-abcd-ef0123456789
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.