JBoss hangs at startup due to antivirus

Solution Verified - Updated

Environment

  • Red Hat JBoss Enterprise Application Platform (EAP)
    • 5.x
    • 6.x

Issue

  • When attempting to start a JBoss server it appears to hang after the following line:
18:41:38,803 INFO  [JMXKernel] Legacy JMX core initialized
  • Why does JBoss take a long time with scanner reported as the highest CPU offender?
  • Whenever I start Jboss 5.1, it is taking more than 1 hour in startup. Why does JBoss take too long time to start ? .
  • Is it OK to run antivirus software on our JBoss servers?

Resolution

  • Perform one of the following steps:
    1. Disable the antivirus.
    2. Configure the antivirus so that it excludes the JBoss' server profile directory.

Root Cause

  • Shortly after JBoss was starting the antivirus was starting and putting all of the jboss pids were sleeping, and only very rarely running. The process consuming the most CPU time was rtvscand (Symantec), which was fully consuming a single core. A similar issue happens on Windows with 'Norton' (also Symantec)

Diagnostic Steps

Components

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