[Satellite6] Candlepin stays in suspended mode, tomcat restart does not help
Environment
Red Hat Satellite 6
Issue
- many actions (subscription related) fail with error that
candlepinis in suspended mode candlepinlogsCandlepin is entering suspend mode for the following reason: QPID_DOWNeven after a restart, despiteqpiddis running and providing service
Resolution
Ensure IPv4 network works fine. If so, restart qpidd service:
systemctl restart qpidd.service
To speed up recovery of candlepin, it is recommended to restart tomcat running candlepin app as well:
systemctl restart tomcat.service
For more KB articles/solutions related to Red Hat Satellite 6.x Candlepin Issues, please refer to the Consolidated Troubleshooting Article for Red Hat Satellite 6.x Candlepin Issues
Root Cause
qpiddservice was being started at a time when IPv4 network was down (and IPv6 was working only)qpiddthen started to listen on IPv6 socket onlycandlepinis however configured / able to connect toqpiddover127.0.0.1only- so any
candlepin's attempt to (re)connect toqpidd- even aftercandlepin/tomcatrestart - fails due to closed socket127.0.0.1::5671 - restarting
qpiddwith IPv4 working will resolve the issue
Diagnostic Steps
katello_events_queuequeue inqpiddis empty, no issue with sending messages thereeventexchange is present inqpiddas well/var/log/candlepin/error.logcontains after eachtomcatrestart:
2019-02-23 16:33:14,199 [thread=localhost-startStop-1] [=, org=, csid=] WARN org.candlepin.controller.ModeManagerImpl - Candlepin is entering suspend mode for the following reason: QPID_DOWN
netstatshowsqpiddlistening on port5671BUT only on IPv6:
# netstat -anp | grep LISTEN | grep qpidd
tcp6 0 0 ::1:5671 :::* LISTEN 5022/qpidd
#
SBR
Product(s)
Category
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.