JCA TRACE logging not working

Solution Verified - Updated

Environment

  • JBoss Enterprise Application Platform (EAP) 6

Issue

  • expected TRACE logging for org.jboss.jca is not seen in server.log
  • enabling TRACE logging for org.jboss.jca, logging or only a portion of what is expected is seen

Resolution

Content from issues.jboss.org is not included.JBJCA-1294 is addressed in the EAP 6.4.6 Update (and later). Prior to the 6.4.6 release please make sure that TRACE logging for org.jboss.jca is enabled when JBoss is bootstrapped. If it isn't, you should try restarting JBoss to make sure JCA picks up the configuration change.

Root Cause

Many (but not all) JCA classes contain a static boolean trace property, meaning that once the class has been initialized, the trace setting for that logger is effectively set in stone. Restarting JBoss is the only way to reinitialize all JCA classes to pick up the changed TRACE setting prior to addressing JBJCA-1294.

Category

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