RHV - Unable to upload images via Admin Portal after upgrading to RHV 4.3

Solution Unverified - Updated

Environment

  • RHV 4.3
  • RHV-M using 3rd party CA

Issue

After upgrading from RHV 4.2 to 4.3, when trying to upload an image in the RHV 4.3 Admin Portal, an error is seen:

"Transfer was stopped by system. Reason: failed to add image ticket to ovirt-imageio-proxy."

The upload is unable to complete.

Resolution

If RHV-M certificates were replaced with third party cert, ovirt-imageio-proxy.conf will need to be modified.

1. Take a backup of the original file.

# cp /etc/ovirt-imageio-proxy/ovirt-imageio-proxy.conf /root/ovirt-imageio-proxy.conf.backup

2. Modify the following lines as referenced below.

ssl_key_file = /etc/pki/ovirt-engine/keys/apache.key.nopass
ssl_cert_file = /etc/pki/ovirt-engine/certs/apache.cer

3. Restart the imageio-proxy and ovirt-engine services:

# systemctl restart ovirt-imageio-proxy
# systemctl restart ovirt-engine

Root Cause

Starting in RHV 4.3, ovirt-imageio-proxy uses RHV-M certificates, if RHV-M certificates have been replaced with 3rd party CA, the imageio-proxy.conf is pointing to the wrong location. This is tracked in This content is not included.BZ# 1637809.


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