File upload fails when PicketLink SSO is enabled in JBoss EAP 7

Solution Verified - Updated

Environment

  • Red Hat JBoss Enterprise Application Platform (JBoss EAP)
    • 7.1.2 and later
  • Security Assertion Markup Language (SAML)
  • Picketlink as SAML Service Provider (SP)
  • File Upload

Issue

  • File Upload Fails with IllegalStateException reported in the logs:

      java.lang.IllegalStateException: UT000017: Form value is a file, use getFileItem() instead
          at io.undertow.server.handlers.form.FormData$FormValueImpl.getValue(FormData.java:304) ~[undertow-core-2.0.20.Final-redhat-00001.jar!/:2.0.20.Final-redhat-00001]
          at org.picketlink.identity.federation.bindings.wildfly.sp.SPFormAuthenticationRequestWrapper.getParameter(SPFormAuthenticationRequestWrapper.java:73) ~[picketlink-wildfly8-2.5.5.SP12-redhat-00005.jar!/:2.5.5.SP12-redhat-00005]
      ...
    
  • File upload (multipart) fails with sizes around or over 20Kb

Resolution

This issue is resolved in EAP 7.2.7+, 7.3.1+, and 7.4.0+.

Notes:
Several issues have been identified that are all fixed in Red Hat JBoss Enterprise Application Platform 7.2 Update 7 (EAP 7.2.7) and EAP 7.3 Update 1 (EAP 7.3.1). Refer to the Root Cause section for the related bug fixes.

Root Cause

Related bugs for file upload issues include:

EAP 7.2

EAP 7.3

Category

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