JBoss EAP 7.2 Management Console Shows Blank Screen in IE11

Solution Verified - Updated

Environment

  • Red Hat JBoss Enterprise Application Platform (JBoss EAP) 7.2
  • Red Hat Single Sign-On (RH-SSO) 7.3
  • Management Console after successful login
  • Microsoft Internet Explorer (IE) 11

Issue

  • Not able to see Management Console
  • Blank Browser screen after login, but works in other browsers
  • Browser Console shows Syntax Error in "polyfill.min.js" and "'fetch' is undefined" among other errors

Resolution

It is fixed in JBoss EAP 7.2 Update 7 and later: Content from issues.jboss.org is not included.JBEAP-17852.
A fix for RH-SSO is expected in RH-SSO 7.3 Update 7.

Root Cause

This is specific to JBoss EAP 7.2 and does not apply to 7.1 or earlier. It also occurs in Red Hat Single Sign-On

It seems to be related to issue Content from github.com is not included.Fetch Breaks with update to 3.0.0 and the upstream issue Content from issues.jboss.org is not included.HAL-1484.

Components
Category

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.