Java heap retention due to JSIP logging in JBoss Communication Platform

Solution Verified - Updated

Environment

  • JBoss Communication Platform (JBCP)

Issue

  • After a few hours we start noticing numerous errors in the logs. Pretty  soon the system runs out of memory and stops processing calls completely.
  • java.lang.OutOfMemoryError: Java heap space

Resolution

  • Upgrade to jain-sip-ri-1.2.JBCP-Jan24-safe.jar that has many logging statements removed, which should allow achieving much more load.
  • As an lternative to patching the server, edit mss-sip-stack.properties and set the following:
    gov.nist.javax.sip.LOG_MESSAGE_CONTENT=false
    gov.nist.javax.sip.TRACE_LEVEL=0
    

Root Cause

  • The server is running with jsip logging turned on, and active threads are printing debug messages.
  • The are many SipApplicationSession objects serialized to replicate due to logging delays.

Diagnostic Steps

Tags

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.