Transfer ownership of an OCP 4 cluster
Environment
- Red Hat OpenShift Container Platform (RHOCP)
- 4
- Red Hat OpenShift Cluster Manager (OCM)
- Existing cluster owned by the wrong organization, user or incorrect or expired entitlements
Issue
- Transfer of ownership of an OpenShift 4 cluster to a different user in the
sameordifferentOrganization. - Cancel the transfer of ownership for an OCP 4 cluster.
- Is there an expiry date for the cancellation of the cluster ownership transfer?
Resolution
It is possible to transfer the ownership of an OCP cluster via the This content is not included.OCM portal. In case that only the pull-secret needs to be renewed, please refer to How to request pull-secret rotation.
Note: For most Managed OpenShift clusters the following procedure applies. However, if you have a non-CCS OpenShift Dedicated cluster or you are transferring to a separate organization refer to Support-Assisted Transfer of Managed OpenShift Clusters.
The full workflow is documented in the Red Hat OpenShift Cluster Manager product documentation: Transferring cluster ownership.
Notes:
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Please ensure to follow the execution of the transfer process as described in the documentation.
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There may be Telemetry issues if you attempt to change the pull secret to the new owner before initiating the transfer in OpenShift Cluster Manager.
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If the pull secret is not changed within 5 days, the process will need to be initiated again.
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If the current cluster owner (user) is inactive then initiate the transfer with the organization administrator in the associated Red Hat account.
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Cluster transfer may take as long as 5 days to complete on a bigger environment.
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On cluster version 4.7.3 and older, cluster transfer triggers a reboot of the nodes. The node reboot after changing the pull secret is no longer needed starting with OCP 4.7.4 as per the documentation.
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Ensure that the telemetry client is enabled on the cluster. (Its usually enabled by default)
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If the cluster stays in an initiated state even after changing the pull-secret then delete the telemetric-client to get the ownership change happen. i.e. run oc delete deployment telemeter-client -n openshift-monitoring. Seems like telemetric-client keeps sending metrics to the old owner if not redeployed. To delete telemeter-client pods you can use following commands:
To delete telemeter-client pod:
$ oc delete pods -n openshift-monitoring -l app.kubernetes.io/name=telemeter-client
Root Cause
If we simply associate the clusters with the new user or organization in This content is not included.OCM, we will see telemetry calls starting to fail. This is because the OpenShift clusters still have the previous user's pull secrets while the clusters in OCM are associated with a different user/organization, causing a validation error. This is why the feature was introduced in the OpenShift Cluster Manager portal.
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