How can a user view/manage systems registered by other users under Red Hat Customer Portal
Environment
- Red Hat Customer Portal
Issue
- A user is not able to view/edit a system which is registered by some other user in the account under Red Hat Customer Portal.
Resolution
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In order to allow a user to view or manage systems which are registered by some other user under the same account, the user must have adequate permissions.
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There are three different levels of this permission:
View/Edit User’s Only: You can only view or edit systems that you have registered to the account.
View All: You can view all systems associated with the account, but you cannot make any changes. This role is typical of someone such as a purchasing agent. This must be set to prevent user from registering systems via subscription-manager.
View/Edit All: You can view and edit all systems and applications registered to the account.
Note : Only an organization admin has the rights to update these settings under the customer portal.
Root Cause
- A user with View/Edit User’s Only permission under the Customer Portal can only view/manage systems registered by him/her.
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