MTC console inaccessible because of OAuth timeout error

Solution Verified - Updated

Environment

  • Openshift Container Platform
    • 4.x
  • Migration Toolkit for Container
    • 1.3

Issue

  • After deploying MTC 1.3 on OCP-4.5 cluster, MTC web console can NOT be accessed.
  • After adding the certificate in browser getting error as The connection has timed out for oauth URL.

Resolution

  • Make sure to have uninterrupted access to the oauth-authorization-server as well as openshift-console from the client system.
  • If proxy is configured on the cluster where the migration-ui is installed, then make sure to have the proxy configuration so browser is able to reach https://api.example.com:6443/.well-known/oauth-authorization-server and UI is rendered.

Root Cause

  • For accessing the MTC-UI from the browser, the access to the openshift-console as well as the oauth url is required.
  • The access to oauth-authorization-server getting blocked because of the proxy configuration on the cluster where migration-ui is running.

Diagnostic Steps

  • Check the logs of the migration-ui pod and see if there is any error.
# oc logs migration-ui-xxxx-yyyy  -n openshift-migration
  • Access the MTC UI and inspect element in the browser to check the network calls.
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