Cooperative Community Support

Solution Verified - Updated

Environment

  • Cooperative Community Support (CCS)

Issue

  • What is Cooperative Community Support?

Resolution

Cooperative Community Support

Cooperative Community Support provides assistance to Red Hat customers that have questions about community-provided software that is often used with our Red Hat products.

Cooperative Community Support (CCS) applies to a select group of components. The list currently includes:

  • Red Hat OpenShift Local (formerly called CodeReady Containers (CRC))
  • Red Hat CodeReady Dependency Analytics
  • odo
  • Podman Desktop
  • Source-to-Image (s2i) CLI

How do I get help?

Help for CCS-enabled offerings is available through the Red Hat ticketing mechanism. The user opens a ticket and identifies the software in use from the list of CCS-enabled offerings. Red Hat’s award winning support team will begin communications through the ticket.

What kind of help can I expect?


Your Red Hat support team will provide information that will lead you to the Subject Matter Experts that write and maintain the software in use. These will be the foremost experts available, and they will be happy to discuss your use of the software and ways improvements can be made. The benefit to you is Red Hat’s knowledge of where the community is located, and how the primary stakeholders can be contacted. In many cases, these are key ingredients in finding a timely solution to some problem in community software.

What kind of SLAs are available?


Unlike fully-supported Red Hat products, there are no SLAs for CCS-enabled software projects. You will be given direct access to the owners of the software, but the urgency at which issues are worked depends on the needs of the owners. (Like all Open Source projects, they are always happy to accept volunteers, if you are willing to contribute to the effort!)

Can this be changed to ‘fully supported’?


Some CCS offerings are more strongly associated with Red Hat supplied products than others. If a strong affiliation exists and if customer demand warrants it, it is always possible Red Hat might ‘adapt’ a project for productization in the future. In the meantime, Red Hat offers Cooperative Community Support to our customers as a way of providing assistance for software we don’t currently offer as a product.

Root Cause

Cooperative Community Support provides assistance to Red Hat customers that have questions about community-provided software that is often used with our Red Hat products.

Category

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