Red Hat Satellite 6 upgrade failing due to dependency errors.

Solution Verified - Updated

Environment

  • Red Hat Satellite 6

Issue

  • When attempting to install/upgrade Red Hat Satellite server the process failed with dependency errors.

       ---> Package tfm-rubygem-timeliness.noarch 0:0.3.10-1.el7sat will be installed
       --> Finished Dependency Resolution
       Error: Package: candlepin-selinux-2.9.30-1.el7sat.noarch (rhel-7-server-satellite-6.7-rpms)
                  Requires: selinux-policy >= 3.13.1-266.el7_8.1
                  Installed: selinux-policy-3.13.1-252.el7_7.6.noarch (@rhel-7-server-rpms)
                      selinux-policy = 3.13.1-252.el7_7.6
                  Available: selinux-policy-3.12.1-153.el7.noarch (rhel-7-server-rpms)
                      selinux-policy = 3.12.1-153.el7
    

Resolution

  • Unset the OS release version.

       # subscription-manager release --unset
       # yum clean all
    

For more KB articles/solutions related to Red Hat Satellite 6.x upgrade failures due to dependency errors, please refer to the Resolving Red Hat Satellite 6.x upgrade failures due to dependency issues KB article.

For more KB articles/solutions related to Red Hat Satellite 6.x Installation/Upgrade/Update Issues, please refer to the Red Hat Satellite Consolidated Troubleshooting Article for Red Hat Satellite 6.x Installation/Upgrade/Update Issues.

Root Cause

  • OS release version is set to RHEL 7.7 or below.

       # subscription-manager release --show
       Release: 7.7
    
SBR
Product(s)
Category

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.