Troubleshoot `insights-client --compliance` upload failures
Issue
When you use insights-client --compliance, sometimes your upload would fail and not show up in console.redhat.com. If you are configured to setup Compliance notifications, you will get an email about the upload failure.
Root Cause
If you received an email about the Compliance upload failure, it is likely due to a few scenarios which are mentioned below.
- Entitlement error - invalid identity or missing insights entitlement
- If this happens, check to see if your system has right subscriptions. Try uploading again. - Failed to download report
- If this happens, it is probably due to a communication error in our infrastructure. Try uploading again. - Invalid report - this means the uploaded report is invalid, probably due to one of the following reasons:
+ Missing data in the upload or corruption - Try uploading again.
+ Wrong format or benchmark
+ OS major version does not match with the policy in Compliance UI - Try to re-register your system and assign a Compliance policy.
+ You are trying to upload a report for a non-existing system - Register your system and add it to the policy.
+ No policy found matching benchmark - Check your assigned policies or reassign the system.
+ No benchmark found matching ref_id - Try to reassign your system to the policy or recreate the policy.
+ No profile found matching ref_id - Try to reassign your system to the policy or recreate the policy.
+ The following rules are missing from profile - Check the profile tailoring, or recreate the policy.
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