Post upgrade to Red Hat Satellite 6.10, provisioning fails with exception:"Could not find virtual machine network interface matching <IP>"
Environment
- Red Hat Satellite 6.10.7
- Red Hat Satellite 6.11
- Red Hat Satellite 6.12 up to the 6.12.4 release.
- Red Hat Satellite 6.13 ( having fog-vsphere 3.6.0 installed )
Issue
-
Unable to provision the client from Red Hat Satellite 6 on one of the subnets.
-
After upgrading to 6.10, deploying a VM on VMware vCenter from Red Hat Satellite fails with the error:
Unable to save: Could not find virtual machine network interface matching xx.xx.xx.xx -
Similar issues were reported for the latest releases of Red Hat Satellite 6.12 and 6.13 as well ( having version 3.6.0 of rubygem-fog-vsphere package installed ).
Resolution
-
This issue was fixed in
fog-vsphere 3.5.3rubygem and was expected to be shipped with Red Hat Satellite 6.12+ but a higher version of that component was shipped and it's missing the expected patch.- Hence the recent occurrences of this problem have been reported to the Red Hat Engineering team via a This content is not included.regression bug 2215426.
-
For Red Hat Satellite 6.13, please open a This content is not included.support case with Red Hat to obtain a patch or hotfix.
-
For Red Hat Satellite 6.12 the issue has been fixed in the 6.12.5 release based on This content is not included.Bug 2228127, by the release of RHBA-2023:4749 - Bug Fix Advisory
-
For Red Hat Satellite 6.11, the issue can be fixed by installing the correct hotfix as explained below:
-
For the satellite running on RHEL 7, refer to the steps in This content is not included.Bugzilla 2119911 comment #28 to apply the hotfix.
-
For the satellite running on RHEL 8, refer to the steps in This content is not included.Bugzilla 2119911 comment #29 to apply the hotfix.
-
-
Reach out to This content is not included.Red Hat Technical Support in case of any further concerns.
For more KB articles/solutions related to Red Hat Satellite 6.x Provisioning Issues, please refer to the Consolidated Troubleshooting Article for Red Hat Satellite 6.x Provisioning related Issues
Root Cause
Please see the first point of the resolution section. A flaw in the product code was fixed but was not properly included in the later releases of the product.
Diagnostic Steps
-
The following errors are observed in the
/var/log/foreman/production.logof the Red Hat Satellite server.2022-08-19T13:59:21 [D|app|27d12fed] Processing task 'Query instance details for client.example.com' from 'Host::Managed Main' 2022-08-19T13:59:21 [D|app|27d12fed] Orchestration::Compute: Trying to match network interfaces from fog <Fog::Vsphere::Compute::Interfaces 27d12fed | server_id="50269259-a089-3b27-7bbe-9e4af4e03684" 27d12fed | [ 27d12fed | <Fog::Vsphere::Compute::Interface 27d12fed | mac="00:50:56:a6:aa:8e", 27d12fed | network="dvportgroup-3567", 27d12fed | name="Network adapter 1", 27d12fed | status="untried", 27d12fed | connected=false, 27d12fed | summary="DVSwitch: e7 e5 0c 50 5f a1 2d e0-cb 19 92 a2 c2 b4 c8 28", 27d12fed | type=RbVmomi::VIM::VirtualVmxnet3, 27d12fed | key=4000, 27d12fed | virtualswitch=nil, 27d12fed | server_id="50269259-a089-3b27-7bbe-9e4af4e03684" 27d12fed | > 27d12fed | ] 27d12fed | > 2022-08-19T13:59:22 [W|app|27d12fed] Orchestration::Compute: Could not match network interface #<Nic::Managed id: nil, mac: nil, ip: "xx.xx.xx.xx", type: "Nic::Managed", name: "client.example.com", host_id: nil, subnet_id: 1, domain_id: 1, attrs: {}, created_at: nil, updated_at: nil, provider: nil, username: nil, password: nil, virtual: false, link: true, identifier: "", tag: "", attached_to: "", managed: true, mode: "balance-rr", attached_devices: "", bond_options: "", primary: true, provision: true, compute_attributes: {"type"=>"VirtualVmxnet3", "network"=>"dvportgroup-789"}, execution: true, ip6: "", subnet6_id: nil> 2022-08-19T13:59:22 [W|app|27d12fed] Could not find virtual machine network interface matching "xx.xx.xx.xx"
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.