UEFI-based Network Install Fails with error "not enough free space on disks"
Environment
- Red Hat Enterprise Linux 7
Issue
- We are trying a network based install on an ESX based guest that is configured with UEFI bios.
- The kernel sees the disks and via the Anaconda (text based) GUI you can select the disk, tell it to "Use All Space" & "LVM" partitioning but the installer repeatedly reports "not enough free space on disks"
Resolution
- Add the following to the kickstart (ks.cfg) file:
part /boot/efi --fstype=efi --size=100
For more KB articles/solutions related to Red Hat Satellite 6.x Provisioning Issues, please refer to the Consolidated Troubleshooting Article for Red Hat Satellite 6.x Provisioning related Issues
Root Cause
- While trying to install on an EFI system, it was not specified as a EFI system partition in the ks.cfg. On BIOS systems, with gpt disklabels, you need the biosboot partition, while on EFI systems you need the EFI partition. The following line would suffice in place of the biosboot line:
part /boot/efi --type=efi --size=100
- Also, booting the installer in EFI mode means the system will be installed to boot only in EFI mode. Similarly, if you install in legacy/BIOS mode, the system will only be bootable in that mode. In the logs, it was booted in EFI mode.
Diagnostic Steps
- Steps to reproduce the issue:
1. The guest boots the grubx64.efi file, reads a default grub.cfg file and starts anaconda.
2. The ks.cfg file is read but the installer fails to identify any disks to install on.
3. The kernel sees the disks and via the Anaconda (text based) GUI you can select the disk, tell it to "Use All Space" & "LVM" partitioning but the installer repeatedly reports "not enough free space on disks"
4. From the shell window the, 64GB, disk can be accessed normally (e.g. partition it, create filesystems, mount them, etc.)
- Important logs to troubleshoot the issue: anaconda.log, storage.log, program.log, and ks.cfg
SBR
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Category
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