Installing RHOCP 4 on vSphere 8.0.3 with network customizations fails
Environment
- Red Hat OpenShift Container Platform (RHOCP) 4
- VMware vSphere 8.0.3
Issue
- IP address disappearing after reboot
- Installing a cluster using user-provisioned infrastructure fails in vSphere 8.0.3
- During installation the nodes lose the IPs configured with
guestinfo.afterburn.initrd.network-kargs.
Resolution
Remove any OS customization provided via vCenter (like vApp properties), or Ansible Automation Platform (APP), since that is not supported and could interfere with the supported guestinfo.afterburn.initrd.network-kargs.
For configuring RHCOS via guestinfo.afterburn.initrd.network-kargs, refer to installing RHCOS and starting the OpenShift Container Platform bootstrap process.
Root Cause
The OS customization in vSphere is not supported and interfere with the configuration provided by the parameter guestinfo.afterburn.initrd.network-kargs. In vSphere 8.0.3 the script that customize the Operating System erases the network configuration written by the ignition process of the RHCOS.
Diagnostic Steps
Identify if there is any OS customization provided via vCenter for the virtual machines, like for example the community.vmware.vmware_guest Ansible module.
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.