Red Hat Satellite upgrade fails during pre-upgrade check with "subscription-manager release is not set to a minor version"
Environment
- Red Hat Satellite 6
Issue
-
During the upgrade of Red Hat Satellite, the pre-upgrade checks fail with the following message:
Check if subscription-manager release is not set to a minor version: [FAIL] Your system is configured to use RHEL 9.7, but Satellite is only supported on the latest RHEL. Please unset the release in subscription-manager by calling subscription-manager release --unset.
Resolution
-
Execute the following command to unset a specific release:
# subscription-manager release --unset -
After unsetting the subscription-manager release, execute the Satellite upgrade again.
For more KB articles/solutions related to Red Hat Satellite 6.x Installation/Upgrade/Update Issues, please refer to the Red Hat Satellite Consolidated Troubleshooting Article for Red Hat Satellite 6.x Installation/Upgrade/Update Issues.
Root Cause
- The release is set on the Red Hat Satellite server through subscription-manager (for example, RHEL 9.7). During the Satellite upgrade, the pre-upgrade validation detects the configured minor release lock and fails because the system is not configured to track the latest supported RHEL minor release required for the Satellite upgrade. Refer to the Operating system requirements for more details.
Diagnostic Steps
-
Verify whether a release is set on the Red Hat Satellite server using following command:
# subscription-manager release --show
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.