Why Virtual data Center subscriptions display "No repository content provided through subscriptions" on Red Hat Satellite 6 server?
Environment
- Red Hat Satellite 6.0
Issue
-
Red Hat Enterprise Linux for Virtual Datacenterssubscriptions do not shows any product repositories under it. -
Other regular subscriptions does.
Login to webui --> Any Context --> Organization --> Any Organization --> Org --> Content --> Red Hat Subscriptions --> Red Hat Enterprise Linux for Virtual Datacenters, Standard --> 1 out of 1 --> Product Content --> Shows "No repository content provided through this subscription."
Resolution
- After setting up
virt-whoand associating theVirtual Data Centersubscriptions with the hypervisors can successfully browse the content for theVirtual Data Centersubscriptions.
For more KB articles/solutions related to Virt-who and Virtual Datacenter (VDC) Subscriptions Issues, please refer to the Consolidated Troubleshooting Article for Virt-who and Virtual Datacenter (VDC) Subscriptions Issues
Root Cause
virt-whonot configured andVirtual Data Centersubscriptions not attached to hypervisor.
Diagnostic Steps
- For further troubleshooting, enable debug logging for Katello on Red Hat Satellite as per KCS
- Perform following steps.
- On Red Hat Satellite webui --> Hosts --> Content Hosts --> Click on host profile name --> Subscriptions --> Make sure VDC subscription is attached --> Click on 'Product Content' --> Take Screen Shot
- Content --> Activation Keys --> Click on activation key name --> Product Content --> Take screen shot
- Content --> Red Hat Subscriptions --> Look for VDC subscription and click on its count --> Product Content --> Take screen shot
- Content --> Product --> Take screen shot
- Content --> Red Hat Repositories --> Exapnd and Take screen shot
- After that generate sosreport with foreman plugin.
Refer KCS article for more information on generating foreman-debug.
Refer KCS article for information on how to generate sosreport. - Revert back the changes done for debug logging.
Provide the generated reports and all 4 screen shots to Red Hat Support for further troubelshooting.
SBR
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