Getting error of "Unit xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx has been deleted (Katello::Errors::CandlepinError)" while doing Manifest Refresh in Red Hat Satellite 6

Solution Verified - Updated

Environment

  • Red Hat Satellite v. 6.x

Issue

  • When performing Manifest refresh on Satellite , will get error similar to
[E|bac|] Unit 9a7168d2-0657-49dc-9556-6077a295abd5 has been deleted (Katello::Errors::CandlepinError)

OR

 Katello::Errors::UpstreamConsumerGone: The Subscription Allocation providing the imported manifest has been removed. Please create a new Subscription Allocation and import the new manifest.

Resolution

These errors indicate that the manifest on the customer portal has been deleted. The UUID mentioned is the UUID of the manifest that no longer exists. The solution to this is to upload a new manifest to the satellite, either through the webui or through the hammer command.

If the manifest has been deleted from the portal, the customer must download a new manifest to upload to the Satellite. The old manifest must first be deleted. Note that this will result in all hosts being un-registered.

The hammer command to upload a new manifest:

hammer -u admin subscription refresh-manifest --organization="Default_Organization"

For more KB articles/solutions related to Red Hat Satellite 6.x Manifest Issues, please refer to the Consolidated Troubleshooting Article for Red Hat Satellite 6.x Manifest Issues

Root Cause

  • Satellite profile or manifest got deleted from customer portal
SBR
Product(s)
Category

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.