Red Hat Satellite manifest import and refresh failures on very large environments

Solution Verified - Updated

Environment

  • Red Hat Satellite 6.7.0
  • Red Hat Satellite 6.7.1

Issue

  • Satellite manifest import and refresh failures on very large environments where tens of thousands of hosts are using a single subscription.

  • The import step will fail when Candlepin encounters read timeouts waiting for one of the update steps because it takes too long to complete.

RestClient::Exceptions::ReadTimeout
Katello::Resources::Candlepin::Owner: Timed out reading data from server (POST /candlepin/owners/{Organization}/imports)

Actions::Candlepin::Owner::Import
Katello::Errors::CandlepinError: Runtime Error This connection has been closed. at org.postgresql.jdbc.PgConnection.checkClosed:767

Resolution

Upgrade to Red Hat Satellite 6.7.2 which includes a fix for this bug (This content is not included.BZ#1851157) in Errata RHBA-2020:3255

For more KB articles/solutions related to Red Hat Satellite 6.x Manifest Issues, please refer to the Consolidated Troubleshooting Article for Red Hat Satellite 6.x Manifest Issues

Root Cause

In extremely large Red Hat Satellite environments, if there many hosts attached to a single subscription (like an Enterprise Service Agreement subscription), the steps to remove and expiring subscription can be very slow at cleaning up related data.

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